js Библиотека JQuery 2.x 

Дата публикации  Дата изменения26.01.15  КомментарииНет   Просмотры1376

Как и обещалось, эта версия оставляет позади старые браузеры Internet Explorer 6, 7, и 8. Но, в то же время, она меньше, быстрее, и может использоваться в средах, где JavaScript код, необходимый для обеспечения совместимости старых IE, часто вызывает проблемы в самом себе.

Однако пользователям волноваться не стоит, поскольку разработчики JQuery все еще поддерживают версию библиотеки 1.х, которая работает и в IE 6/7/8. Следует продолжать пользоваться jQuery 1.9 (и следующей – 1.10) на сайтах, где нужна поддержка старых браузеров.
http://coderhs.com
Если переход на версию 2.х осуществляется с версии ниже 1.9, то рекомендуется использовать Плагин Миграции и прочитать "Руководство по апгрейду" к версии JQuery 1.9, поскольку там содержится много новой информации по изменениям. Использовать плагин просто, просто вставьте его в HTML страницу после jQuery и запустите браузер, чтобы увидеть генерируемые им сообщения:

<script src="http://code.jquery.com/jquery-2.0.0.js"></script>
<script src="http://code.jquery.com/jquery-migrate-1.1.1.js"></script>

Применение:

jQuery 2.0 предназначена для современного вэба; версия jQuery 1.x, работающая со старыми браузерами, будет поддерживаться еще несколько лет. При желании можно организовать работу 2.0 на новых браузерах, и 1.х на старых,

<!--[if lt IE 9]>
    <script src="jquery-1.9.1.js"></script>
<![endif]-->
<!--[if gte IE 9]><!-->
    <script src="jquery-2.0.0b2.js"></script>
<!--<![endif]-->

хотя этого не требуется — проще использовать на сайтах jQuery 1.x, поскольку она работает во всех браузерах.

В jQuery 2.0 есть несколько моментов, которые больше не будут поддерживаться в 1.х, поскольку 2.х является гораздо лучшим выбором. Это относится, как правило, к сценариям не для вэб сайтов, которые предназначены для поддержки старых IE, что сейчас уже не актуально. А именно:

    Google Chrome add-ons
    Mozilla XUL apps и Firefox extensions
    Firefox OS apps
    Chrome OS apps
    Windows 8 Store (“Modern/Metro UI”) apps
    BlackBerry 10 WebWorks apps
    PhoneGap/Cordova apps
    Apple UIWebView class
    Microsoft WebBrowser control
    node.js (объединено с jsdom или подобным)

Многие из этих сценариев/дополнений продолжают дорабатываться и содержать свои собственные наборы правил или ограничений, которые отличаются от используемых на интернет сайтах при подключении jQuery.

Некоторые существенные изменения в 2.0

IE 6/7/8 больше не поддерживаются: помните, что под это может попасть IE9 и даже IE10, если они используются в режиме совместимости со старыми версиями. Для избежания этого рекомендуется всегда использовать X-UA-Compatible тэг или HTTP заголовок. Если есть возможность использования HTTP заголовка, то это несколько лучше для производительности, поскольку позволяет избежать потенциального рестарта парсера браузера.

Уменьшенный размер: файл 2.0 на 12% меньше 1.9.1, благодаря отсутствию требуемых только IE 6, 7, и 8 патчей. Можно было бы еще сократить код и улучшить производительность, но старые Android/WebKit 2.x браузеры сейчас самое слабое звено. В настоящее время проводится работа по отслеживанию рынка Android 2.x, с целью определения возможности обеспечения совместимости и полагается, что это не займет много времени.

Теперь можно исключить комбинации включения 12 разных модулей для создания пользовательской версии библиотеки, и она при этом будет даже меньше. Новый минималистический движок селекторов, основанный на тонкой обертке querySelectorAll API браузера, позволяет уменьшить размер до менее, чем 10KB, в минимизированном и gzippированном формате. Читайте об этом в README и помните, что любые плагины, используемые вами, должны быть включены в подмножество выбора вашей сборки библиотеки.

jQuery 1.9 API эквивалентность: jQuery 2.0 is API-совместим с 1.9, что означает, что все изменения, задокументированные в jQuery 1.9 "Руководстве по апгрейду", так же относятся и к jQuery 2.0. Если вы еще не обновились до jQuery 1.9, может быть, стоит попробовать ее сначала. Не забудьте при этом воспользоваться Плагином Миграции .

  • В исходник включены полная и min версии библиотеки jQuery 2.0

  Размер:  97,74kB | Изменен: 29.04.13 | Загрузок: 29
Бесплатные курсы

Категории

Теги: , , , ,

Оцените материал:

Рейтинг: 0.0/10 (0)


КомментарииКомментарии:

Нет комментариев к этой статье.


Поля, обозначенные как *, обязательны.





Максимальная длина сообщения 900 символов. Осталось   символов

 

Старые →← Новые